“常见开发问题”的版本间的差异

来自艺搜天下
跳到导航 跳到搜索
(创建页面,内容为“*/lib/ld-linux.so.2: bad ELF interpreter: 没有那个文件或目录 可能是因为64位系统中安装了32位程序,解决方法: yum install glibc.i686 -y…”)
 
第13行: 第13行:
 
  Protected multilib versions: libstdc++-4.8.5-36.el7_6.2.i686 != libstdc++-4.8.5-36.el7.x86_64
 
  Protected multilib versions: libstdc++-4.8.5-36.el7_6.2.i686 != libstdc++-4.8.5-36.el7.x86_64
 
则先yum install libstdc++
 
则先yum install libstdc++
 +
 +
*error while loading shared libraries: libz.so.1
 +
yum install zlib.i686
 
[[Category:开发问题]]
 
[[Category:开发问题]]

2019年7月12日 (五) 01:58的版本

  • /lib/ld-linux.so.2: bad ELF interpreter: 没有那个文件或目录

可能是因为64位系统中安装了32位程序,解决方法:

yum install glibc.i686 -y

重新安装以后如果还有如下类似错误

error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

再继续安装包

yum install libstdc++.so.6  -y

如果冲突:

Protected multilib versions: libstdc++-4.8.5-36.el7_6.2.i686 != libstdc++-4.8.5-36.el7.x86_64

则先yum install libstdc++

  • error while loading shared libraries: libz.so.1
yum install zlib.i686